Announcement

Collapse
No announcement yet.

2106 Left Front PSI Sensor

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2106 Left Front PSI Sensor

    I installed a RidePro e3 system in my 1963 Riviera back in 2010. The only past issue I encountered is when I would reconnect my battery and sometimes my compressor wouldn't fire. It only happened a handful of times.

    Today, I could hear the solenoids click when I pressed (-) and nothing on all four when I pressed (+). Back in January I had a similar thing happen and when I pressed a preset they worked then everything started working again. I haven't had the car out since January.

    -Compressor sensor works (150psi)
    -I've tried multiple hard resets
    -I've inspected the harness
    -I've swapped the FL connector to a different PSI sensor
    -My battery is at 12.7v with the car not running (I have to lift the car before I fire it)
    -Ground on the ECU is good

    I then tried to calibrate my system which led me to the 2106 error then I reset my software.

    Any help our thoughts would be greatly appreciated.

    Thx.

    Andy

    PS - I never hooked up the height sensors.
    Last edited by Metalflake; 08-26-2018, 05:15 PM.

  • #2
    DO NOT, DO NOT, DO NOT re-calibrate. If there is an issue Calibration will not fix it. You loose all information saved when you recalibrate so we are truly back at square one.

    The LF sensor error is thrown when the system opens the LF inflate valve, but the pressure in the LF does not raise.

    You MUST start the car. Valve operation becomes erratic at 10.5V. If the car is not running and a compressor comes on the valves will be under 10.5V and may not work.
    It could also be that the valves are stuck. This sometimes happens if the vehicle sits for a long period of time without the valves being triggered. The air in the tank helps keep the inflate valve closed (called "air over seat" valves). If the valves are older, round, silver coils the plunger may have become stuck in the orifice (we have since made the plunger a harder durometer which mitigates this issue). You can try pressing an inflate button, then smacking the corresponding inflate valve with the handle of a screw driver. Typically frees it up.

    You may want to check out our valve service article:
    https://www.ridetech.com/info/tech/s...valve-service/

    Comment


    • #3
      britt@ridetech.com Thx for the quick reply! I have they older silver coils. I'll give the valves a whack with a screwdriver and let you know if it fixes the problem.
      Last edited by Metalflake; 08-28-2018, 01:48 AM. Reason: Spelled reply wrong.

      Comment


      • #4
        I finally got back to messing with my system. I connected my battery and the solenoids starting working again.

        Now my compressor won't fire, and all my air readings at the panel are bouncing including the air tank. When I run through set-up, the compressor does that little test fire, and it's reading continues bouncing. When the system tests the 4 airbag pressure sensors, then their readings stop bouncing. I tried disconnecting the compressor's pressure sensor, and it didn't help. I also tried cutting power before disconnecting the compressor's sensor.

        I then followed these instructions:

        https://www.ridetech.com/forum/forum...does-not-start

        With all the sensors unplugged the reading are all still bouncing.

        Any ideas?

        -Andy

        Comment


        • #5
          When you say the numbers are bouncing, is it just a few psi, or is it a lot (like 60psi or more)?

          Push the Menu button, go to System Settings, then System Info and let me know which software versions are shown.
          We'll go from there.

          Thanks!

          Comment


          • #6
            I miss diagnosed the problem. My pressure sensors work fine once there's air in the system. The problem is my compressor won't start. When I go through the calibration steps, the system fires the compressor for 1 second, but the sensor won't read the air pressure. The numbers bounce as I describe before. I get the 4.8v at the tank sensor, so there is power there. Could it be a bad sensor? Here's a video of the control panel as I go through the calibration. https://www.youtube.com/watch?v=vaPTZcY05VM Thanks again, Andy

            Comment


            • #7
              Hey Andy. I believe I talked to you on the phone yesterday. Let me know if you have any updates after checking on the harnesses!

              Comment


              • #8
                Hi Josh, That was me! I did check the harnesses and grounds. I changed the ground point on the ECU and checked the voltage at the end of each sensor. I had power at all of them. Did you take a look at the link to the youtube? Have you seen that before? Thanks for replying! -Andy

                Comment


                • #9
                  To run my compressor I need to bypass the grey wire come coming from the ECU. Again, the compressor will fire once during set up via the grey wire but will not run. As it runs through the set up I get stuck at "9. Determines suspension type- different suspension types will utilize different software." It lowers it from max height then once down just clicks and clicks. I let it go for 30 minutes and it didn't stop.

                  Comment

                  Footer Placeholder (Do not delete)
                  Working...
                  X